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1.0 Quick Start Guide  

 This quick start guide will help you get your system up and running in as little time as 

possible.  The guide includes both setup and explanation of basic software features. 

1.1 Instrument Setup 

Follow the hardware setup instructions provided by IonOptix and setup the fluorescence 

equipment.  Likewise follow the setup instructions for other equipment used in the experiment 

such as the length controller, force transducer, stimulator, 600A Digital Controller and 

VSL/HVSL sarcomere measurement system.   

1.1.1 Attaching the VSL/HVSL Camera to the Cell Framing Adapter 

Attach the VSL/HVSL camera to the end of the IonOptix Cell Framing Adapter (CFA) 

using the following procedure. 

1) Loosen the thumbscrew holding the C-mount adapter to the CFA and then remove the 

C-mount adapter (see Figure 1). 

2) Screw the C-mount adapter onto the camera (see Figure 2). 

3) Slide the camera through the camera fork (the camera fork is specific to the camera 

model you have) that is attached to the end of the Cell Framing Adapter and once the 

C-mount adapter is fully inserted then tighten the thumbscrew (see Figure 3).   

Tighten the thumbscrew until you feel resistance and then loosen it one full turn.  

This allows the camera to be rotated along with the Cell Framing Adapter. 

 
Figure 1 Camera, C-mount and Cell Framing Adapter (note thumbscrew on top) 
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Figure 2 C-Mount attached to camera 

 

 
Figure 3 Camera attached to Cell Framing Adapter 
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1.1.2 Signal Connections 

Using the supplied BNC-BNC cables make all of the signal connections between the 

FluoroDAQ controller and the 604A Signal Interface as follows: 

 

Table 1 FluoroDAQ/604A Signal Interface Connections 

Connection Function 604A Signal Interface 

(front panel) 

FluoroDAQ  

(back panel) 

1 Numerator Aux1 Path 1 Out 

2 Denominator Aux2 Path Out 2 

3 FluoroDAQ Trigger TrgOut1 Trig In 

4 Operating Mode TrgIn1 Mode 1 Out 

5 Operating Mode TrgIn2 Mode 2 Out 

 

1.1.3 Stimulator Connections 

Using the supplied BNC-BNC cables connect the stimulator to the apparatus and to the 

604A Signal Interface as follows: 

 

Table 2 Stimulator/604A Signal Interface Connections 

Connection Function 604A Signal 

Interface 

(front panel) 

701C Stimulator 

 (front panel) 

Apparatus 

1 Stimulator 

Trigger 

Stimulator External Trigger No Connection 

2 Stimulator 

Output 

No Connection Pulses Out Connect to 

electrode connector 

 

1.1.4 PC Startup 

The 950A FluoroTrack software comes pre-installed on the 600A PC.  Attach the 

keyboard, mouse and monitor (we suggest you attach the monitor using the DVI connector for 

improved performance) to the PC.  The Linux operating system will determine the native 

resolution of the monitor and automatically set the video resolution to that value.  It is therefore 

important that you turn on the monitor before turning on the PC.  If desired you can run two 
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monitors with the 600A PC, please contact Aurora Scientific Inc. for more information about this 

option. 

1.2 Software Registration and Activation  

The FluoroTrack program must be licensed before it will run on your new PC.  The following 

procedure should take about 5 minutes to complete.   

You will need: 

 PC with ASI software to be activated 

 PC with an internet connection (does not have to be the 600A PC) 

 Product Key found on the serial number tag for the software. 

 

1. Click on the Activate Software icon located on the desktop. 

2. When the Activate window opens follow the on-screen directions as shown in Figure 4 

(remember Linux is case sensitive).  The first step will be to enter the Product Key which is 

a 5 character key with the format of three numbers followed by a letter and then a final 

number, e.g., 017J3.  Ensure you enter the Product Key and not the serial number.   

3. After pressing the Enter key the ASI Activate program will provide you with an Activation 

Code which is an alpha-numeric character string consisting of three groups of 5 characters 

each separated by dashes, e.g., 7P001-740x0-130x3.  

 
Figure 4 ASI Activate Window 
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4. On the PC with internet access, point your web browser to: 

http://www.AuroraScientific.com/activate 

5. Enter the Activation Code returned by the ASIActivate program, your contact details and 

then click on the Activate! button.  See Figure 5. 

6. Copy or write down the license code returned by the webpage.   

7. Enter the license code, and then enter the root user’s password (By default this password is 

set to “root”. If you have changed it, then enter your new password.) 

8. Repeat as required for additional ASI software.  For example, if you have a PC with both 

600A and 901B software, you must complete this procedure twice. 

9. Click on the desktop icon to start 600A and then click on the 950A menu item to start the 

FluoroTrack program.  If the program starts then the license was installed correctly.   

 

Should you encounter any issues with this procedure, please contact ASI by phone or email, 

and we will be happy to help you with the process. 

 
Figure 5 ASI Product Activation Website 

http://www.aurorascientific.com/activate
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1.3 Linux and Desktop Overview  

 Once all components of the system have been connected together then turn on the 

monitor and the PC.  The PC should go through the normal power on self-tests and then the 

Linux operating system should be loaded.  Once loaded, a Windows-like desktop should appear 

with a task bar at the bottom of the screen and several icons located on the desktop.  The desktop 

is shown in Figure 6.  The most frequently used icons will be 600A, VSL, Home, and data. The 

taskbar at the bottom of the screen shows the current windows that are open and provides a 

simple method of switching between the windows.  Simply click on the taskbar item that you 

want to switch to and that window will become the current and top one.  The most frequently 

used icon at the bottom of the screen is the K icon at the far left of the screen.  The K icon is 

similar to the Start button in Windows.  It provides access to programs and also allows you to 

shut down the computer properly.  Just like Windows, Linux must be shut down properly since 

the file system is updated during the shutdown procedure.   

 For specific actions like licensing software you may need to obtain superuser privileges.  

This is done by clicking on the xterm icon and then typing the following in the xterm: 

su 

Password:  root 

 

If you change the root password (superuser password) there is no way for ASI to recover 

the password if you forget or lose it.  Therefore please record the superuser password and 

store it in a safe place.   

Many users will elect to connect the 600A/950A/HVSL PC to a network.  Since the PC 

was shipped with no login password and the root password is not secure be sure to set 

strong passwords before connecting the PC to a network.  A strong password should not 

be a recognizable word, it should be a minimum of 6 characters containing letters, 

numbers and at least one special character (&, ^, $, #, @, !).   

1.4 Starting the FluoroTrack Program 

In most applications the researcher will be using three software programs during the 

experiment, these are: 600A Digital Controller, 900B/901B VSL/HVSL and 950A FluoroTrack. 

Once the PC finishes the login process you will see an icon on the Desktop for 600A and for 

VSL or HVSL (depending on which system you own), see Figure 6.  You will not see an icon 

for 950A FluoroTrack because it is a module installed within the 600A program.  Make sure you 

license 600A, VSL/HVSL and FluoroTrack before continuing (see section 1.2 Software 

Registration and Activation for details).   

Start the 600A program by clicking on the 600A icon.  Setup 600A according to the 

instructions found in the 600A manual.  Before starting VSL/HVSL make sure that the camera is 

powered.  The program sends setup information to the camera when the program starts so 

improper camera operation may occur if the camera is not powered when the program starts.   

Click on the VSL or HVSL icon to start the program.  Setup the VSL/HVSL program according 

to the instructions found in the VSL/HVSL manual.   
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FluoroTrack is a module installed within 600A so you will notice on the top menu bar of 

the 600A program a 950A menu item, click on this menu to start the 950A FluoroTrack program.   

 

 
Figure 6 Desktop with 600A, FluoroTrack and VSL Programs Running 

 

1.5 FluoroTrack Program Main Window 

When the FluoroTrack program starts the main window will open showing the 

FluoroTrack scope screen and the controls for the IonOptix FluoroDAQ fluorescence controller 

(see Figure 7).  The main window is separated into four main sections: the top menu bar, the left 

side control pane, the lower control buttons above a status information line and finally the Scope 

graph area.  The main window can be repositioned, minimized and resized as per normal 

Windows type controls.  When the program is closed it remembers the size and location of the 

main window and will start next time at the same size and in the same location.  Because three 

programs must be displayed simultaneously you may want to use a dual monitor setup.  The 

600A PC is capable of driving two monitors; please contact ASI for instructions on setting up 

Linux for display on two monitors.  The Linux desktop and all program windows use normal 

Windows-type controls for manipulating the display windows.  

The menu bar located along the top of the screen includes the following headings (shown 

in bold) with the drop down menu items listed below.   
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 File    Edit    Setup Tags Analysis Stimulus  600A  Help 

 New Session Display Settings Open View Open Open Protocol Quick Start 

 Quit Show Controls Close Edit (F1-F9) Close Close Setup ASI950A Help 

       Main FluoroDAQ Help  

        About 

 

Clicking on any menu item opens a drop-down menu that lists the commands available 

under the selected heading.  A detailed description of each command is provided in Chapter 

Error! Reference source not found.. 

 
Figure 7 FluoroTrack Main Screen 

 The left side control pane includes controls for the FluoroDAQ fluorescence controller.  

These include Status and Mode readouts, control buttons to turn the UV light source on or off 

and to set the operating mode.  In the middle on the left is a section for recording and showing 

the current background settings for the Numerator and Denominator signals.  The Record 

Background button records the current background levels of the Numerator and Denominator 

inputs.  These are automatically stored by the program and the applied to all data displayed after 

the Record Background button is pressed.  If the researcher knows the background signals 

(measured in volts) then they can also type these known values in the Num and Den text boxes.  

At the bottom of the left control pane are display controls that allow the time base for the Scope 

section to be set and a Pause/Run button.  Pressing the Pause button allows a researcher to stop 

the live scope output and then scroll back through the data for up to 4 hours. 

 The lower control buttons and the status information line provide the main experiment 

control buttons from the 600A program (you can start a test from 600A or from 950A; the button 

does the same job regardless of where it is pressed).  The control buttons include Start Sequence, 

Start Test, Next Test and Stop Test.  The 600A control buttons are all explained in the 600A 
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Instruction Manual.  At the bottom of the screen is a status line which provides information 

about what the program is doing at any given time. 

 The Scope display provides a real-time scrolling display of the data channels along with a 

Tags bar at the top of the screen and a 600A graphical status indicator at the bottom of the 

screen.  Clicking on Edit>Display Settings will open the Display Settings window.  This window 

is shown in Figure 8 and allows the channels to be selected, the colour of the each channel to be 

set, the relative size of each channel, the background colour scheme as well as a control button 

which will set the channel colours the same as they are currently defined in the 600A program.   

 
Figure 8 FluoroTrack Display Settings Screen 

The Tags bar at the top of the main screen area provides a graphical indication of where 

the researcher has tagged the data (see Figure 9).   
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Figure 9 FluoroTrack Main Screen with Tags 

There are two methods of inserting a tag into the data, either left click the mouse with the 

pointer on the Tags bar which creates a tag at that point in time and opens the Tag Editor, as can 

be seen in Figure 10, or press one of the functions keys from F1 to F9.  Pressing a function key 

creates a tag and automatically populates the text box with Tag information that the researcher 

has previously assigned to that particular F key.  Text can be assigned to function keys by 

opening the FluoroTrack Tags screen by clicking on Tags>Edit Tags (F1-F9) as is shown in 

Figure 11. 
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Figure 10 FluoroTrack Main Screen with Tag Editor Open 

 
Figure 11 FluoroTrack Tags Window 

At any time the researcher can view all tags created since the program was started.  This 

is done by clicking Tags>View from the main menu.  The View Tags window opens and shows 

the tags created along with their creation time.  Clicking on any tag line will cause the main 

screen display to be paused and then the display will jump to the time that the selected tag was 

created.  Clicking on any of the headings will sort the Tags by that heading.  See Figure 12 for 

the View Tags window. 
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Figure 12 FluoroTrack Tags Window 

The 600A/950A graphical status bar located at the bottom of the Scope window provides 

a simple method of determining exactly what the 600A and 950A programs are doing at any 

time.  Refer to Figure 13 which shows the 600A Signals display.  The display is separated into 

two sections; the first is above the horizontal green line and the second below the line.  Above 

the line you will notice red vertical lines and yellow sections.  The red lines show the time at 

when a stimulation pulse (stim) was produced.  The red lines are plotted with a width 

proportional to the stimulation pulse width.  When the time base of the graph doesn’t allow the 

width to be shown then the red lines will be one pixel wide which ensures that the stimulation 

signals can be seen even for the shortest pulses.  The yellow areas show where the UV light 

source was turned on, i.e., shutter (shtr) open.  Ratio and Calcium Fluorescence data is only 

collected while the shutter is open.  Below the line the display can be either green or blue.  Blue 

indicates when a protocol is running on the 600A (test) and green indicates when data collection 

is occurring (data).  

 

 
Figure 13 600A Signals Display 

 

1.6 Quick Start Example – Papillary muscle Force-frequency with calcium 

This example will describe the steps required to perform force-frequency with calcium 

measurements in intact papillary muscle fibers.  One example of a study similar to this is 

provided in  

Charged residue alterations in the inner-core domain and carboxy-terminus of α-tropomyosin differentially 
affect mouse cardiac muscle contractility 

Robert D Gaffin, Carl W Tong, David C Zawieja, Timothy E Hewett, Raisa Klevitsky, Jeffrey Robbins, 

Mariappan Muthuchamy, J Physiol. 2004 December 15; 561(Pt 3): 777–791.  

 

http://www.ncbi.nlm.nih.gov/pmc/articles/PMC1665389/
http://www.ncbi.nlm.nih.gov/pmc/articles/PMC1665389/
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The experiment involves mounting a right ventricular papillary muscle between a force 

transducer and length controller in a temperature controlled bath.  The muscle is electrically 

stimulated and the resulting force and calcium transients are measured.  The test is repeated at 

different stimulation frequencies to obtain the force-frequency relationship with calcium 

measurement.  

 

1.6.1 Equipment Required 

1. 1500A Small Intact Muscle Test System 

Consisting of:  

 322C High Speed Length Controller 

 400A Force Transducer 

 600A Digital Controller 

 701C High Current Field Stimulator 

 801C Small  Intact Muscle Apparatus 

2. VSL/HVSL Sarcomere Length System 

3. Fluorescence Photometry System 

Consisting of:  

 950A FluoroTrack Software 

 960A FluoroDAQ Data Acquisition Controller 

 961A HyperSwitch Dual Excitation Light Source 

 962A Cell Framing Adapter 

 963A Photomultiplier Subsystem 

 964-x Microscope Components – x specifies microscope manufacturer 

4. Inverted Microscope 

5. Vibration Isolation Table 

6. Misc. Lab Equipment – glassware, pump, suction, tools, etc. 

 

1.6.2 Method 

 For the purposes of this method we will assume that all of the instruments are set up 

correctly, all signal connections are made and the setup of 600A and VSL/HVSL has been done.  

Details of setup of 600A and VSL/HVSL can be found in their respective instruction manuals. 

 

1.6.3 Experiment/Software Setup 

1) It is strongly recommended that you power the instruments on in the following order: 

 Cairn Xenon Power Supply 

 960A FluoroDAQ - ensure the PMT switch on the front of the FluoroDAQ is OFF 

and then turn on the FluoroDAQ 

 961A HyperSwitch 

 600A PC 

 322C High Speed Length Controller 

 400A Force Transducer 

 701C High Current Field Stimulator 
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 825A TEC Controller 

2) Log into the 600A PC. 

3) Turn on the camera and then start the VSL/HVSL program.  Ensure that the program is 

calibrated correctly for the objective that you will be using to image sarcomere length 

(normally a 40X objective is required for accurate SL measurement) also calibrate the 

low magnification setting of the program for either a 10X or 20X objective that is used 

for observing the tissue, measuring tissue dimensions, etc.). 

4) Start the 600A program.  Use Edit>Display Settings to choose the channels you would 

like to view on the 600A main window.  You can also setup specific colours for each 

channel.  We recommend that you view Force In, SL and Stim on the 600A main screen. 

5) Open the 600A Scope screen and choose the channels to observe in real-time.  We 

recommend that you view Force In.  Scope provides a scrolling display of the selected 

data channels and is an excellent tool for observing the long term trends in data.  For 

example it is very easy to use Scope to see force changes with time that are related to 

stimulation frequency or other control variables. 

6) On the 600A menu bar click on the 950A heading which will open the FluoroTrack 

program.  Click on Edit>Display Settings and choose the channels you would like to 

observe on the 950A main screen.  Please be aware that you can view all of the 600A 

channels through 950A as well as the fluorescence channels and sarcomere length.  Since 

950A also includes many of the experiment control buttons you could choose to 

minimize the 600A main screen and just run the experiment using the 950A main screen.  

For now we will assume that both main screens from 600A and 950A will be on the 

Desktop and therefore we recommend that you view Force In, Numerator, Denominator, 

Ratio and SL on the main screen of 950A.  You will note that you can automatically set 

the channel colours of the 950A display to be the same as 600A.  This is recommended as 

you will then be able to easily recognize a channel on either main window simply by its 

colour. 

7) Open the Manual Stimulation controls by clicking on Stimulus>Open.  The control 

window will be as is shown in Figure 14. 

8) Set the Frequency to 60 bpm (beats per minute) or to 1.0 Hz (the program automatically 

converts between the two units, so use the units of most convenience).  Set the Pulse 

Width to 6.0 ms (or whatever you determine is best for your experimental setup). 

 
Figure 14 Manual Stimulation Window 
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1.6.4 Tissue Setup 

1) Start superfusion through the 801C bath and then mount the papillary muscle in the 801C 

bath.  The valve and the ventricular regions should be attached to the force transducer and 

the lever system.  Refer to the 801C instruction manual for information about mounting 

methods. 

2) With the tissue slack, record the zero level force (Record Fin) using the 600A Setup 

window. This sets the zero level for the force transducer.  You can open the 600A Setup 

window either from 600A or from 950A.  From 950A you would click 600A>Setup on 

the main menu. 

3) Start stimulation pulses to pace the tissue by clicking on the Start button on the Manual 

Stimulation window.   

4) Adjust the bundle length until you observe force twitches on the 600A Scope screen.    

5) Optimize the bundle length and stimulation current or voltage (depending on the 

operating mode of the 701C Stimulator) to obtain maximum force twitches.   

6) With the optimum length set use VSL/HVSL on Low Magnification to measure the tissue 

length and cross section dimensions.  Record the reference length in the 600A Setup 

window and also press the Record Lin button to record the length datum.   

 

1.6.5 Fluorescence Photometry Equipment Setup 

1)  Observe the tissue using VSL/HVSL and set the microscope to a minimum of 40X 

objective in order to see the sarcomere pattern.  In some cases sarcomeres will not be 

visible and if this is the case then no SL data can be collected. If sarcomeres are visible 

then use the MyoHandle on the Cell Framing Adapter (CFA) to rotate the camera so that 

the sarcomeres are vertical as shown on the VSL/HVSL screen.   

2) Use the horizontal and vertical aperture adjustments on the CFA to set a region over 

which SL and Calcium measurements will be taken.  You should ensure that the aperture 

is set so that there is only tissue within the aperture.   

3) On the 950A menu bar open the Setup window (Figure 15).   Use the Selected Mode drop 

down control to set the operating mode of the program the same as what you have set on 

the FluoroDAQ controller.  In most cases you will use the Dual Excitation Interleaved 

(FURA) mode.  

4) Turn off the room lights and then turn on the PMT (switch located on the front panel of 

the FluoroDAQ instrument – see FluoroDAQ instruction manual).  

5) Open the shutter by clicking on the Shutter Open button located on the main window of 

the FluoroTrack program.  

6) You should now be observing Numerator, Denominator and Ratio signals on the main 

window of FluoroTrack.  At this point FURA-2 has not been loaded into the tissue so the 

Numerator and Denominator signals should not change as the tissue contracts.  If a 

change in Numerator and/or Denominator is seen during contractions then adjust the size 

and location of the aperture until these signals stay constant during a contraction.  Any 

changes seen at this point will most likely be due to the tissue moving out of the aperture 

and causing a change in background. 
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Figure 15 Setup Window 

7) If the Numerator or Denominator signal is too large you may need to change the Filter 

Flipper on the HyperSwitch to switch in a neutral density (ND) filter which will reduce 

the amount of light being seen by the PMT.  You may want to record fluorescence data 

for each of the ND filter settings so that you can see the effect of the full range of the 

available filters.  Note: Flipper position 1 corresponds to no ND filter and the filter 

increases with increasing Flipper number.  Flipper position 6 corresponds to ND 1.3 

which filters 95% of the light (5% transmission).  

8) Once you have selected the appropriate ND filter then record the background 

fluorescence signal by clicking on Record Background on the main window.  Note: 

background must be collected when there is no FURA loaded in the tissue.   

9) Close the shutter by clicking Close on the FluoroTrack main window.  This closes the 

HyperSwitch shutter and stops the calculation of Ratio. 

10) Shut off the PMT.  It is a best practice to only power on the PMT when you are taking 

measurements.  Leaving it off at all other times will increase lifetime and prevent 

possible damage caused by bright light. 

 

1.6.6 FURA-2 Loading 

1) Using the method described in the referenced paper load the tissue with FURA-2 dye.  

This procedure often takes 1 to 1.5 hours.  Many researchers decrease the stimulation 

frequency during loading.  This can be easily done by using the Frequency control on the 

Manual Stimulation window. 
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1.6.7 Controlling the Collection of Data 

There are two methods of controlling the fluorescence photometry equipment and taking 

Calcium measurements.  1) manual method which can only be used if you do not need any of the 

600A protocol control functions, 2) 600A control method which must be used if you want to use 

600A protocol control functions or if you want to automate the experiment.  600A protocol 

control functions allow the researcher to control the length, force or SL of the tissue during an 

experiment.  They also include functions for controlling the stimulator, for changing baths on an 

802D apparatus and for controlling the 950A and the VSL/HVSL programs.  600A protocol 

functions also allow you to automate much of the experiment.   

In this example experiment we want to collect Force, Numerator, Denominator and SL 

data at several different stimulation frequencies.  The experiment will involve setting a desired 

stimulation frequency, waiting for the force to stabilize, collecting data from 40 twitches and 

then repeating these steps several times for each of the desired frequencies.  The noisy nature of 

fluorescence signals can be greatly improved by collecting many twitches and averaging them to 

produce an average twitch with much lower noise.  For this example we will collect data at 1, 

1.5, 2, 2.5 and 3 Hz.  We will not be controlling tissue length nor do we need to control the 

VSL/HVSL program.  Therefore either of the two data collection methods could be used.   

 

1.6.7.1 Manual Method of Collecting Data 

The 950A automatically logs data to a file whenever the program is open.  This file can hold 

a maximum of 4 hours of data and if the program is open for more than 4 hours a new data file 

will be automatically created every 4 hours.  Alternatively the user can initiate a new data file at 

any time by clicking File>New Session on the FluoroTrack main menu.  However, ratio data is 

only collected whenever the shutter is open.  The manual method involves opening and closing 

the shutter whenever you want to collect data.  Each Open/Close will generate a “record” in the 

data file.  Records are the method used to separate different recordings.  The manual method uses 

the following procedure.   

1) Use the Manual Stimulation control and set the stimulation frequency to 1 Hz. 

2) Monitor the Force In signal using the Scope function of 600A.  Set the time base for 

Scope long enough that you can see 2 or more minutes on the screen at a time.  Whenever 

you change the stimulation frequency you will typically see a change in the peak force.  

This change often occurs over a 1 to 2 minute time period.  The procedure involves 

waiting for the peak force to stabilize and then going on to the next step.  

3) Ensure the room lights are off and then switch on the PMT using the switch on the front 

panel of the FluoroDAQ controller. 

4) Press the Open button on the 950A main window which will open the HyperSwitch 

shutter and start the collection of data.   

5) Count the number of twitches and when you reach 40 press the Close shutter button on 

the 950A main window.  Alternatively you can simply time how long the shutter is open, 

at 1 Hz you will require 40 seconds, at 1.5 Hz you will require 27 seconds, at 2 Hz 20 

seconds and so forth. 

6) Repeat steps (1) through (5) for each of the stimulation frequencies in your experiment.  

For this example you will repeat the steps at frequencies of 1.5, 2, 2.5 and 3 Hz.  
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7) When the experiment is complete set the stimulation frequency back to 1 Hz. 

8) Proceed to section 3.6.8 for measuring the fluorescence background after the test. 

 

1.6.7.2 600A Protocol Method of Collecting Data 

1) During the FURA-2 loading you will have plenty of time to load the experimental 

protocols required during the experiment.  These protocols are included in Appendix B at 

the end of this manual.  You will also find the protocol files in the /pro directory on the 

600A PC. 

2) To use 600A to control the experiment and collect data you will require a series of 

protocols that set the different stimulation frequencies required and control the 

HyperSwitch and collect data.  These protocols are put together in a sequence file which 

controls the execution of each individual protocol.   

3) Click on Protocol>Open on the 600A main menu or on 600A>Protocol on the 950A main 

menu to open the 600A Protocol window. 

4) Click on the Sequencer Tab at the top of the 600A Protocol window and then click on 

Load and pick the sequence called: Force_Freq_950A.seq.  The sequence is shown below 

as Figure 16.   

5) Examination of the sequence file shows that it consists of a series of protocols that first 

set the stimulation parameters and then collect 40 twitches of data.  At the end of the 

sequence the stimulation frequency is set back to 1 Hz. Manual timing is used after each 

of the stimulation setup protocols.  Once the stimulation protocol executes the Next Test 

button found at the bottom of the 950A main window will un-grey.  When the researcher 

wants to start data collection they simply have to press the Next Test button and the next 

protocol will execute. This allows the researcher to monitor peak force and choose when 

to start data collection.  After each of the data collection protocols the sequence timing is 

automatic which means that the next stimulation frequency will be automatically set as 

soon as the current data collection finishes.  The time can easily be changed to a fixed 

wait time between setting a new frequency and collecting the twitches if the researcher 

wanted to configure the test that way. 
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Figure 16 600A Sequencer Window 

6) Each protocol listed in the sequence file is printed in Appendix B and is provided in the 

/pro directory on the 600A PC.  A typical stimulation protocol is shown in Figure 17 and 

the Stimulation Parameters are shown in Figure 18.  A new 600A control function has 

been created called Sync-Stimulus.  This function must be the first function called by the 

protocol and it causes the start of the protocol to coincide exactly with the next stimulus 

pulse produced.  Sync-Stimulus can be used with any protocol when stimulation is 

already occurring.  The function will also synchronize a new stimulation profile with one 

that is already occurring; this avoids the problem of generating stimulation pulses that are 

out of sync which can disturb the pacing of heart tissue.  As can be seen in Figure 18, all 

of the stimulus profiles required by the experiment have been programmed; to change the 

stimulation frequency it is then a simple matter of calling a different Stimulus profile 

number. 
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Figure 17 600A Stimulation Protocol 

 
Figure 18 600A Stimulus Window 
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7) The test protocol that collects the data and controls the 950A is shown in Figure 19.  This 

protocol starts with a Sync-Stimulus command and contains a new function, FLA-

Trigger, which controls the 950A fluorescence system. The FLA-Trigger command opens 

and closes the HyperSwitch shutter based on the parameters used in the command.  The 

FLA-Trigger function uses two parameters, the first controls the shutter and the second 

sets a delay time.  A 0 in the shutter parameter closes the shutter while a 1 opens the 

shutter.  The delay time operates like other delays for 600A functions and allows the user 

to open/close the shutter at a time after the time when the function is issued.  This allows 

synchronization of the shutter control with other functions such as length, force or SL 

controls.  

8) Once the sequence has been loaded it is a simple matter to start the execution of the 

sequence by click the Start Sequence button on the 950A main window.  Each of the 

protocols will execute with the start of all of the collection protocols requiring the user to 

click the Next Test button when they want to collect fluorescence data.  Note: the 

FluoroDAQ does not control the PMT power so you must remember to turn on the PMT 

before starting the sequence.  Since the total execution time of the sequence is only 10-15 

minutes it is reasonable to leave the PMT on for the entire sequence.  However, if 

desired, you could turn on the PMT prior to each click of the Next Test button and then 

turn it off as soon as you see the frequency change to the next value. 

9) During execution of the sequence protocols data will automatically be collected and 

placed in the files that you specified on the Sequencer window.  These are 600A data 

files which also contain all of the 600A data and SL.  Note however that data will also 

have been collected by the 950A program and will be available in the log file for that 

session.   

10) After the sequence completes proceed to section 3.6.8 for instructions on measuring the 

background after the test completes.  
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Figure 19 600A Twitch Data Collection Protocol 

1.6.8 Measuring Fluorescence Background after the Test 

1) After the test is complete many researchers use a solution of manganese (Mn
2+

) to quench 

the FURA-2 present in the tissue.  Turn on the PMT and then open the shutter to monitor 

the Numerator and Denominator signals during the quenching process.  This allows you 

to determine the point at which the FURA-2 is completely quenched. 

2) Once this level is reached the fluorescence background is measured by clicking on the 

Record Background button.  Usually this final background is the one used during analysis 

instead of the background obtained before adding FURA-2.   

 

1.6.9 Analysis 

FluoroTrack includes powerful twitch analysis functionality.  Each time the shutter is opened 

a “record” is created.  Records are closed when the shutter is closed.  All closed records can be 

viewed and analyzed either during or after the experiment.  Use the following procedure to 

perform twitch analysis. 

1) Click on Analysis>Open on the main 950A menu bar.  This will open the Twitch 

Analysis window and display the View Records screen as is shown in Figure 20. 

2) The Analysis window includes a top menu bar which provides the following headings 

(shown in bold) and the drop down items shown below. 
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 File Setup View 

 Save Data Open Time Series – Single Record 

 Load Data Close Transients – Single Record 

 Close  Transients – All 

   History 

 

 
Figure 20 Analysis - Recording History Window 

3) Assuming that you have just complete the collection of data then all of the records 

associated with your experiment should be shown on the View Records screen.  Click on 

the record of interest and then click on either the View Time Series or View Transients 

button located in the bottom right corner of the window. 

4) The View Time Series graph, see Figure 21, will show the signals obtained versus time 

and this will be the same as you saw on the main 950A screen.  You can zoom the data 

record by left clicking the mouse at a point of interest and then, while holding the button, 

drag out a box to enclose the data you are interested in viewing.  The screen will 

automatically zoom to the region you have selected.  When the data has been zoomed a 

scroll bar will appear below the graph which allows you to scroll through the data using 

the currently defined time base. Pressing the magnifying glass symbol will un-zoom the 

graph.  Also note that Tags are shown on the Time Series at the time when they were 

created. 
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Figure 21 Analysis – View Time Series window 

5) From either the Recording History window or from the Time Series window you can 

click on the View Transients button and a graph showing each transient (twitch) will be 

shown.  In this case the x axis is twitch number as is shown in Figure 22.  The View 

Transients display is where the analysis takes place and where the results of the analysis 

are shown.  The window is split into two sections; the left side shows each twitch plotted 

against twitch number, the right side shows the average of the twitches that are shown on 

the left side of the window.  

6) The relative size of the two sections can be changed by clicking and holding the left 

mouse button on the vertical bar between the two sections and then dragging the bar back 

and forth.  

7) The twitch analysis process involves summing all of the displayed twitches and 

calculating an average twitch.  This averaging process greatly reduces the noise on the 

signal.  Noise reduces as you increase the number of twitches included in the average.  

Experience shows that an average of about 40 twitches provides a good result, however 

the particular circumstances of your experiment will determine the best number to use.  It 

is important to understand that the average Ratio value is computed from the average 

Numerator and average Denominator values and not from averaging ratios calculated 

from each individual twitch.  Any noise on the Denominator signal tends to create much 

larger noise levels on the Ratio signal, therefore it is important to calculate Ratio from a 

quiet signal and thus average Ratio = average Numerator / average Denominator. 
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Figure 22 Analysis - View Transients window 

8) The Twitch Analysis Setup menu item opens the Setup window which is used to control 

the Twitch Analysis process.  See Figure 23 for details of the Setup window.   

9) The Setup window is separated into 6 sections: Trace Display, Twitch Length (%), 

Average Twitch Filters, Backgrnd, Average, and Select Parameters. 

10) The Trace Display section provides controls to determine which data channels (signals) 

are displayed on both the View Time Series and View Transients windows.  Controls are 

also provided to set the relative size of each data channel. 

11) The Twitch Length (%) section provides controls that set the amount of data to be used 

for each twitch during the analysis.  The pre-trigger value sets the amount of data before 

the stimulation pulse.  This value is set as a percentage of the total time between 

stimulation pulses.  The post-trigger value sets the amount of data after the stimulation 

pulse.  This value is also set as a percentage of the total time between stimulation pulses.  

The baseline value controls how much of the data before the stimulation pulse should be 

used for calculating the baseline value for the twitch.  This is also set as a percentage of 

the total time but is internally limited to a maximum equal to the pre-trigger percent. 

12) The Average Twitch Filters section allows the user to filter the raw signals and the 

derivatives of these signals using a Savitsky-Golay smoothing filter.  The order of the 

filter is set in the text boxes next to each channel label.  

13) The Backgrnd section allows you to manually or automatically set the background for the 

Numerator and Denominator signals.  If these values are known then you can simply type 

the baseline values in the N and D text boxes.  When you click on Apply then all data is 

recalculated using these background values.  An alternative method for setting the 

background is to choose a background record out of the available records.  If, for 

example, you took background as your second record (as is shown in Figure 20) you can 

click the checkbox beside the Backgrnd label and then choose the appropriate record 

number using the spin button next to the Rec label.  The N and D values for that record 
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will automatically be placed in the N and D text boxes and all data will be recalculated 

using these values.  

14) The Average section allows the user to specify which channels are averaged and shown 

on the right side of the window.  The four available channels are listed along with a dX/dt 

button and a Stats button.  Selecting the dX/dt button will display the derivative of all of 

the selected channels.  Selecting the Stats button will print the selected statistics to the 

right of each average graph (as is shown in Figure 22) 

15) The final section is the Select Parameters section which allows the user to specify which 

statistics are to be calculated and displayed. 

 
Figure 23 Analysis - Setup window 

16) Click on File>Export Data to export the analysis data to a file.  The export function will 

export the data as is shown in the current display.  If you are on View Time Series and 

you have zoomed in on a section of data and chosen, for example Force, Numerator, 

Denominator and Ratio then when you export the data you will get a data file with the 

time series including only these channels for the time period currently being shown.  If, 

for example, you are on the View Transients window then when you export data you will 

get three files: the first which will be the twitches currently displayed for the channels 

selected, the second will be the average signals for the channels selected and the third file 

will be the statistics for the channels and parameters currently selected.  You can import 

these exported files into Excel or most other programs.  The data file format is ASCII 

delimited data and typical files are shown in Appendix A. 
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1.6.10 Program Shutdown 

The 950A program should normally be closed using File>Quit and then the 600A and 

VSL/HVSL programs can be closed in the same manner.   

In order to shut down the PC you must first log out and then tell Linux to shut down the 

PC.  Never simply power down the PC since this can result in file corruption.  To log out click 

on the K icon at the left end of the task bar at the bottom of the desktop (this is analogous to the 

Start button for Windows) and select Shutdown.  A dialog box will appear where you can select 

Shut down.  The PC will be powered off automatically when Linux finishes its shut down 

procedure. 

 


